• snaveekima
    Hi, I'm running on ubuntu 18.04. A number of my files are failing to backup, with the detailed report stating "permission denied".

    How can I make sure that cloudberry is running as root and able to backup everthing? Is there an installation or run-time setting I've missed somewhere?

  • MattAccepted Answer

    Running this command via Terminal should help:

    sudo chown root:root /opt/local/CloudBerry\ Backup/etc/plans/*

    It changes the permissions for the plans to root and that usually helps with most of the permission problems.
  • scottdd
    This is a slightly aging post, but I just wanted to add a note - this did help quite a bit, but I'm still getting more issues than I like. More research to come. My system runs Mint 19.3 (Ubuntu under the hood).

    Here's the link to the mac/linux knowledge base with similar advice: link, but Matt's suggestion to specify root is not present in the KB.

    Thanks, @Matt for the tip!
  • scottdd
    final update - this fix offered by @Matt worked perfectly for me. You might also need to restart the cloudberry-backup service
  • Arfa
    Just working through similar issues, but I'm finding I have no directory:
    /opt/local/CloudBerry\ Backup/etc/plans/

    My install is in: /opt/local/CloudBerry Backup
    And I have no etc/plans sub folders and no *.cbb files anywhere to be found.
    My backup was configured to save plan config on the external storage (BackBlaze B2). So, I presume that's the only location of my .cbb files? In which case, how does one manage their permissions?

    Further to this, is there a recommended approach to backing up multiple user home directories? Each user setup their own backup plan with their own permissions? Create a backup plan as root which has permission to read all user folders? Or add an admin-backup user to all user groups, and create plans under that user (assuming all user files are readable as their group)?
  • Matt
    If you're unsure of the logs location it's better to contact support, the configuration files are always saved locally.

    As for the multi-user setup, the most secure option is to change permissions for each plan individually.
    Setting root permissions is just the easiest option and suits most of our clients.
  • Adam Henriksen
    I found that the CloudBerry Backup plans directory for my install of Ubuntu 18.04 is in:
    /opt/local/Online Backup/00000000-0000-0000-0000-000000000000/plans/
  • Dennis Faucher
    Thank you so much!! This worked for me. These are the steps I used (although my chmod 666 is overkill. I need to experiment with that one)

    sudo chown root: root /opt/local/Online Backup/00000000-0000-0000-0000-000000000000/plans/{a2483730-77c8-451b-aff6-a87bcfb95b0f}.cbb

    sudo chmod 666 /opt/local/Online Backup/{a2483730-77c8-451b-aff6-a87bcfb95b0f\}.cbb

    sudo systemctl status cloudberry-backup
Add a Comment