• David Leigh
    I've just installed CloudBerry Explorer (free) for the first time. I specifically wanted it to connect to my Google Drive account. When I select the Google account I want to use, I get this message:

    This app is blocked

    This app tried to access sensitive info in your Google Account. To keep your account safe, Google blocked this access.

    I had expected an OAuth 2.0-style confirmation dialog but no other option was given. Is there a way around this?
  • David Gugick
    Please open a support case from Tools - Diagnostic. Add the following description to the submission in the dialog: "Logs for Anton T". The support team will review and offer an alternative method for connecting to Google Drive.
  • David Leigh
    Sorry, but that doesn't help me. As I said, it's the FREE product. Support said I couldn't open a ticket because I'm on the free product. So if there is an alternative method, perhaps someone could share it in the forums?
  • David Gugick
    They know it’s the free edition and are waiting for you to open the case. If they tell you otherwise, you let them know I and Anton T requested you get to open a case.
  • David Leigh
    Anton from support gave me this very helpful info that I'm passing on for anyone else having this issue:

    The issue with adding the Google Drive account using the "Installed Application" authentication method appears to be caused by the changes on the Google side. We have created an escalation to our R&D Team so they can investigate what exactly is causing this issue and how we can handle it, however, the investigation process may require communication with Google and this may take a considerable amount of time. More than that, by our management decision, we're going to discontinue the support of some storage providers in CloudBerry Explorer soon including Google Drive since we've already discontinued the support for these storage providers in our flagship product - CloduBerry Backup. Please refer to this article for more info:


    We recommend using storage providers like Google Cloud Platform, Amazon S3, Microsoft Azure, Wasabi, BackBlaze B2 instead. 

    In the meantime, the only workaround is using the "Service Account" authentication method instead of the "Installed Application" method to access your Google Drive with CloudBerry Explorer. Please follow the instructions below:

    You need to use the "Service Account" option in your Storage Account settings:


    In order to retrieve the information you need to add the storage account, go to your Google APIs dashboard:


    Click "Enable APIs and Services":


    Search for Google Drive API and enable it:


    Go to the "Credentials" in order to see the Service Accounts you can use for authentication in the CloudBerry Explorer. 

    If you don't have any Service Accounts, please create it and make sure it has the "Owner" role:


    Please download the p12 key associated with a Service Account and add a new storage account in CloudBerry Explorer using the Service Account email and a p12 key. 

    Data inside of Drive wouldn't be visible in Explorer right away. To view and access the data, the customer has to share a file/folder with the Service Account:


    And also make the service account the owner of the file/folder. That leaves the main account with no ability to take the ownership back. Other than that, the customer should be able to upload the data through Explorer and it should be then accessible on Google Drive.


    If that does not work for you for some reason, we do not have any other workarounds at the moment, and since we're going to discontinue the support of Google Drive soon anyway, we would recommend switching to Google Cloud Platform or any other storage provider we've mentioned above. 
  • David Gugick
    Can you verify the Service Account method worked for you?
  • David Leigh
    Have not had a chance to test it yet. I'll try and remember to post back when I do.
  • Hans Z
    I've had the same This app is blocked message while trying to connect to Google Cloud. I tried the service account workaround but it would still give me denied errors. See attached.
    tmp22 (38K)
Add a Comment