• Mary Strimel
    I migrated to a new computer and brought /home and everything along with me. Before migrating I exported my Cloudberry configuration, then imported it on the new box. Cloudberry loaded the backup settings, but then proceeded to make entirely new copies of all of my data on the backup media, filling my storage and costing $$. Why is it doing this? I tried syncronizing the backup media from within Cloudberry before running the backup, but it still made a duplicate copy of my data. For my /home directory in particular, it prepended "x2f" on the directory, so it backed up to "/x2fhome". I have no idea why it did that. Ideas are appreciated
  • David Gugick
    Did you give the new machine the same backup prefix as the old one? If not, that's why. If you did, we'll have to look into it further.

  • Mary Strimel
    thank you for the prompt reply! My "Advanced" tab does not have an option for a backup prefix (see file).

    However, under the "storage" tab it displays the prefix as "mythbox" which I believe is the same as it was before (that's the name of the original machine, and this one also).

    I think when I imported the Cloudberry configuration file, it also imported the correct prefix. I'm just not sure what else I should have done / should do to make it use my original backups.
    Cloudberry advanced settings (30K)
  • David Gugick
    It's not Advanced tab in Settings. It's in the Storage configuration. Is that the same place you are saying you checked when you say "Storage tab"? If so, are you positive they are the same prefix? Usually the data in the actual storage will use that prefix in the main folder - you may see something like the following as the main folder in backup storage (CBB_ followed by the PREFIX_NAME).

    Each Storage has it's own prefix option, so please check the new machine against the old one and also verify what root folder names were created (if different) on the old and new machine.
  • Mary Strimel

    Thank you, now I see what you mean for the Storage options. I'm now certain that they were the same prefix, because the file structure for the original backup includes "/CBB_mythbox"
    So to narrow the question, I am wondering why Cloudberry created "\x2fhome" and is backing up to that instead of "/home", see attached file. I'm interested in making sure I can restore correctly.
    Cloudberry file structure (38K)
  • David Gugick
    Are you certain that is not the name of the folder on the Linux machine? I do not think that is coming from us, but I can ask Support.

    So you are saying you followed the directions exactly as detailed in article I posted:
    1. Registered the same cloud storage exactly as you used previously
    2. Selected the same Bucket
    3. Ensured the backup Prefix was the exactly the same
    4. Waited for the repository sync to complete (and you are not using AWS S3 Glacier)
    5. Verified your old backups were showing up in the Backup Storage tab
    6. Created a backup plan with the same folders selected

    Last question: Same version and distribution of Linux? If so (or not) what Linux are you using?
  • Mary Strimel
    Hello again,
    I didn't follow the directions, but only because I thought they didn't apply to my situation. I exported the CBB configuration from the old computer using Cloudberry's "export" button, and imported it to the new computer. This seemed to obviate the need to create duplicate backup plans: I assumed that was the point of the "import/export" function i.e.,, to avoid the need to create new ones. My old ones loaded with the same prefix. So, to go step by step with the instructions:
    1. No I did not register the cloud storage because it registered automatically when I loaded the configuration, and is working.
    2. Did not need to select a bucket - that setting was imported.
    3. Prefix is identical
    4. Yes, I manually synced and waited for it to complete
    5. to be honest I'm not sure the linux version has a Backup Storage tab that displays the backup tree. I see it on the screenshots for Windows - maybe I'm just being dense. Any guidance welcome!
    6. Cloudberry loaded my old backup plans when I imported the configuration, so I did not create new ones.

    Now I have an additional issue that Cloudberry is failing to start. I am running Linux Mint (basically Ubuntu) so if you have a hint as to how to uninstall it so I can re-install, that would be great.

    Once I get it reinstalled, do I have to manually recreate my backup plans following the above directions, even though I exported them a couple of days ago?

    Thanks again for your help.
  • David Gugick
    I do not believe the Export and Import do anything with cloud storage accounts. At least from what I see in the product - only local accounts are exported since they have no credentials. It's backup / restore plan focused. The prefix is not a part of the backup plan. It's a part of the storage account.

    So, let me ask: Where are you backing up - storage type?

    There's a backup storage option on the left in the Linux UI.

    As far as uninstalling, many ways in Mint. Find the item in the start menu and right-click uninstall, use software manager, use the command line. Your backup plans will be preserved on uninstall, but if you are concerned, simply export them first.
  • Mary Strimel
    I am backing up to an external USB drive and also to an Amazon S3 account. Both destinations were "found" automatically when I imported the old configuration. I am backing up my home directory, photos, music, home video, and /etc. Probably < 150 GB although I'm not sure.

    I uninstalled Cloudberry with "dpkg -r cloudberry-backup" and got a confirmation message, however, upon reinstalling, it still won't start. I tried the same drill using "dpkg --purge" and reinstall, got a warning that /opt/local/ files wouldn't be removed, so I purged those files manually and reinstalled -- the gui still won't start. The command line version does start.

    If I can get it going again, I will be very happy.
  • David Gugick
    you'll need to reach out to support for assistance. I just do not have the expertise to help you with an uninstall issue on Linux.
Add a Comment