• merkl
    I was doing a short test restore from two glacier vaults. On the first vault i did an expediated restore of a single file under a meg in size. That took about 35 minutes.

    On the 2nd vault, I decided to restore 25 files, each of which is under 1 meg. It's been running for 9 and half hours now and nothing has been restored. This is longer then it's supposed to take for a standard restore, let alone expedited. Is there any way for me to determine what the issue is that's preventing this? CB hasn't thrown an error or anything...the restore is still listed as 'restoring...'. It says it downloaded 2kb, 0 of 25 files.

    It also says total files size: 1.2mb. If that's supposed to be the size of all the files, I'm pretty certain that's wrong. It should be a few mb in total.
  • merkl
    I cancelled that restore and tried doing it again with just a single file and it failed after 2 minutes due to an incorrect decryption password (i didn't specify one). Now I've got to hope I can remember what password i used. But why did that first restore run for over 9 hours? I used the same exact restore plan, i just edited the file selection to a single file.
  • David Gugick
    the preparation phase on Glacier side does not do any downloading. All AWS is doing is staging the data from Glacier to S3 so can effectively be downloaded by you. The newer S3 Glacier is a great solution for long-term storage and archival purposes. If you plan on doing any type of planned restores from your data, then I would not recommend you use Glacier as your target. If price is driving you to Glacier there are other options available to you that would provide hot cloud storage at a low cost. You can even consider using different AWS storage classes to reduce your storage costs over regular S3 Standard. The best thing I can recommend is try to wait it out. I've seen many reports from customers using our and competitive products over the years reporting that the preparation phase is taking longer than planned. I'm not exactly clear on how Glacier works under the hood, but I believe it may be preparing the entire vault to be downloaded. I don't know that you can simply grab a few individual files from Glacier and let it process just those files. I would check the AWS docs to see if they provide more information on actually what's going on.
  • merkl
    This is really frustrating. I just tried it again, this time using a password i think I might have used. And this time it was running for over and hour before i cancelled it.

    I don't mind if it takes a few minutes longer then what's expected. But this is kinda nuts. That last one was running for over 9 hours. The docs on amazon's site says an expedited request is supposed to process in 1-5 minutes.

    Is there any way to determine where the problem is? I don't feel like waiting several hours doing this, especially since right now I'm just trying to figure out if i have the right password. Having to wait hours in between each attempt would be a pain.

    Thanks for your help
  • merkl
    I read your previous reply about how to get an encrypted file without first decrypting it. it was a bit over my head - i'm not super familiar with using aws storage options, other then using CB to backup files.

    Is there no way to force CB to download a file in it's encrypted state and then decrypt it after? The main thing I am trying to do right now is determine if i have the correct password for this particular vault. If thought I could just do a couple of expedited requests on a single file until I found the password I used. But if it's going to keep failing like this, that's going to make this process a lot harder.

    I believe I run into an issue like this once before and someone from support said I could download the individual file using CB explorer to download the file. Although I can't remember how I would then decrypt it if I did manage to download it.
  • David Gugick
    How much data are we talking about? Restoring from Glacier can be very expensive, especially for testing under these circumstances. If it's not a lot of data, consider re-uploading to S3 Glacier and when you're certain the data is successfully stored, delete your old legacy Glacier vaults.
  • merkl
    Just to be clear - i'm only using expedited to restore a few small files just to test that everything is working. I plan on doing the bulk of the restore using a standard request. I did finally manage to get the file downloaded with the correct password. So i don't need to do any expedited restores now.

    Also, i can't reupload anything since I dont have the files, which is why i'm trying to do the restore :)

    It seems like it's working now - assuming the standard restore doesn't run into whatever issue the expedited restore was running into. I just hope I don't waste hours waiting for it to start and nothing happens.

    Thanks for your help again. Hopefully I wont need to bother you with more questions, assuming the actual restore works.
Add a Comment

Welcome to MSP360 (CloudBerry) Forum!

Thank you for visiting! Please take a moment to register so that you can participate in the discussions!