• MerleOne
    0
    Hi,

    I have Outlook Pro 2021 installed on a Win10x64 PC and I have observed that, when I select as folder to be included in a file backup the following <C:\Users\%user%\AppData\Local\Microsoft\Outlook>,
    the .ost files are not backed up.

    Since some of them are quite big (4 Gb for my gmail account), I'd like to save them.
    It is as if they were excluded but I cannot find in which setting.
    Is there a way to have them saved with CBB 7 ?

    Thanks.
  • David Gugick
    113
    I do not why they are skipped. Possibly they are open in Outlook (is Outlook running?) and you have not selected the VSS option for the backup plan. If that's the case, the OST files will be skipped as they are open in Outlook. If you're not sure what has the OST file locked, then download Process Explorer from Microsoft and type in the OST file name in the search bar and you'll see who has the file open.

    But...

    There is usually no need to back up OST files. They are offline files and unless you've marked items as local only, they will only contain cached data from the server. If you lost an OST it would be recreated automatically. If you tried to copy an OST to another machine and set up a the Gmail connection, you'd likely get an error and need to recreate anyway.

    PST files, on the other hand, should be backed up as they may contain information not available on the server. You can archive older items from the OST / Server to a local PST if you want.

    Either way, if you want to back them up, you should be able to using the directions above.
  • MerleOne
    0
    Hi,
    Thanks for your faster than light answer !
    Outlook is actually fully closed when i try to save them and VSS option is selected, so I see no reason why they are not saved. There is no error message as well, I would at least expect some indication.
    I will try to see with process explorer if they are otherwise locked.
    I understand why it is generally a bad idea to save them but here it is just for a possible restoration on the same PC to avoid re-download, saving some polar bears in the process...
    I'll keep you updated...
    Regards,
    .merle1.
  • MerleOne
    0
    PS : process explorer show no *ost* file locked after Outlook has been closed and CBB still omits them. Strange...
  • David Gugick
    113
    If you had VSS selected, it would not matter if the OST were open. All I can guess is that you do not have that folder selected for the backup. Please verify the folder location from Outlook (right-click top-level folder, Data File Properties - Advanced) and verify that location is selected. If you have explicit file selections in that folder for backup, then you may have missed the OST file. Or, you may not have the folder selected at all.

    If you're positive the whole folder is selected, then check other backup settings:
    * Do not back up hidden and system files - if selected... files can be flagged as system or hidden and would not be backed up. You can check files from File Explorer by showing the Attributes column or running ATTRIB on the file from a command window.
    * Do not back up locked files - should be unchecked
    * Do not back files of these types (make sure if used that OST files are not entered) - best to use the Backup all files in selected folders

    If that does not work, go to the History tab in the backup agent:
    * Click the files toolbar button
    * Select the plan in question from the drop-down list
    * Select the Period in the toolbar
    * Look for the OST file (you can try the Operation: Failed to start, but look at the full list sorted by file to see if the OST file is in there with some message)

    Next, go to the Backup Storage tab and navigate to the storage in question and then to the OST folder. Make sure you do not see the OST file in backup storage.

    Other questions: What is the storage target for these backups?
  • MerleOne
    0

    Hi,
    Thanks again for spending time looking into it. See my answers below :
    "If you had VSS selected, it would not matter if the OST were open. All I can guess is that you do not have that folder selected for the backup. Please verify the folder location from Outlook (right-click top-level folder, Data File Properties - Advanced) and verify that location is selected. If you have explicit file selections in that folder for backup, then you may have missed the OST file. Or, you may not have the folder selected at all."
    The whole Outlook folder is selected, all files are saved except the .ost : for instance xxx.ost.log is saved but not xxx.ost.

    If you're positive the whole folder is selected, then check other backup settings:
    * Do not back up hidden and system files - if selected... files can be flagged as system or hidden and would not be backed up. You can check files from File Explorer by showing the Attributes column or running ATTRIB on the file from a command window.
    * Do not back up locked files - should be unchecked
    * Do not back files of these types (make sure if used that OST files are not entered) - best to use the Backup all files in selected folders

    * Do not backup hidden and system files is unchecked, same for locked files, no string is defined for "do not backup these types", at least at job level. I have not found a global exclusion setting for all jobs.

    If that does not work, go to the History tab in the backup agent:
    * Click the files toolbar button
    * Select the plan in question from the drop-down list
    * Select the Period in the toolbar
    * Look for the OST file (you can try the Operation: Failed to start, but look at the full list sorted by file to see if the OST file is in there with some message)

    This is the strange part, the .ost files are not in the log, it's as if they were not present in the folder but they are.

    And the .ost files are not the the storage area, besides the execution was way too quick for saving 5GB of data.

    Last question, the storage area is local, a folder on an external HDD.

    Regards,

    .merle1.
  • David Gugick
    113
    All I can think is maybe there's some file permission set on those files that do not allow the backup service account to see them at backup time. You can check your backup service account in the agent to see what you're using and make sure that it could see those files.https://help.msp360.com/cloudberry-backup/backup/about-backups/backup-service-account

    Short of that, I think you're going to have to open a support case. You could also try creating a second backup job just for that single OST file as a test to see what happens.
  • MerleOne
    0
    Hi,
    Thanks a lot, will check that. Excellent suggestion the dedicated backup job with only the .ost files, it should help narrowing down the issue. Will let you know...
    Regard,
    .merle1.
  • MerleOne
    0
    Hi again,
    I think I found the solution : I just looked at the .ost file attributes and there is one I was not famiiar with, the "I" attribute. After googling it, it means the file is not to be indexed. I have used the default setting for the backup job, Fast NTFS Scan, and I suspect these files are not scanned during the first steps of the backup job, hence not backupped. I'll try with another specific job without Fast NTFS Scan but I am confident it will work.
    Thanks for your help !
  • David Gugick
    113
    If that's the issue, it might be a bug. So reply backup once you complete that second test and I will send your helpful analysis and results to the engineering team for review.
  • MerleOne
    0
    Hi,
    Will do that but only next week at best, my being out for a few days (IRL)... Thanks again !
    Sincerely,
    .merle1.
  • MerleOne
    0
    Hi, I was able to perform the test and I confirm, unselecting Fast NTFS Scan allows CBB to save the .ost files. What kind of log do would be helpful ?
    Thanks.
  • David Gugick
    113
    Nothing to me, but you can submit logs to support from Tools - Diagnostic and explain what you found. I’ll send this post over to engineering but you should notify support as they’ll keep you posted on what’s going on.
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment