• Gleb
    34
    We are excited to announce a new update to Remote Assistant being released.
    The product team has made some good progress, check it out yourself


    New features

    - Auto-Reconnect for Dropped Connections

    Now Remote Assistant Client will show "Connection is lost. Trying to reconnect..." when the Client experiences troubles with networking (no improvements for network troubles on the Host side)

    If the network restores the connection within 5 minutes - the connection is re-established automatically with no additional confirmations or anything.
    More than 5 minutes - the Host will receive confirmation pop-ups (depending on the settings), Client might connect with View Only too.

    This works for any connection type: PIN access or Unattended

    If PIN and/or encryption key changes while RA was reconnecting - the appropriate "enter PIN/key" dialog will be shown.

    In case the Host cancels connection during the reconnection - this DOES NOT count, the connection will be restored.

    Note: Improvements related to unstable networking on the remote Host side are also on our roadmap.


    - Remote Host Reboot and Reconnect

    This works only during unattended access connection, only when logged into a user session (does not work on the Windows authentication screen)

    Does not work for Quick Support by design.

    The Host informs the Client it has started reboot.
    The Client sees a screen with a notification and <Try to reconnect> button.
    As soon as the Host is online and RA Service is ready, the connection should be restored automatically.


    - Pin Reset Frequency + Pin Complexity settings
    lfyihh8ud0sz22lo.png

    Also, now a long Pin is divided into groups:
    4 digits: XXXX
    6 digits: XXX XXX
    8 digits: XXXX XXXX
    10 digits: XXXXX XXXXX


    - Pin brute force protection

    The Host will now "ban" the Client that fails to authenticate to a Host with an incorrect PIN multiple times in a row: 20 attempts within 12 hours

    The "ban" is removed automatically after 12 hours.


    - An option to change playback device within Remote Assistant during connection.
    It's in the top control panel, under the "sandwich" menu.



    Bugs fixed

    - The issue with hotkeys (Alt, Ctrl, Shift, Winkey etc) being stuck
    - The issue with RA service not starting at system boot on Windows Server 2016
    - Multiple improvements on performance (incl. sound and NAT traversal)



    UX improvements

    - During Unattended Access "Access using PIN" doesn't look like you NEED TO click it - it's a URL instead of a button now
    - Encryption and Unattended Access are now two independent options

    - RA chat is no longer shown above Windows locked screen
    - File Transfer window no longer appears behind the RA window

    - RA Client no longer "remembers" invalid encryption keys for Hosts
    -RA Client no longer "remembers" (and will automatically "forget") connections with incorrect ID
    - RA Client can "forget" previously successful connections - just press the X at one

    - There is now an option to keep Aero enabled and an option to (not) hide the wallpaper.
    It's in the top control panel, under the "sandwich" menu.
  • Steve Wasiura
    0
    Hi Gleb,

    Can the remote computer be upgraded while connected to CBRA remotely? Or does it need to be done in person at the remote computer, because the installation will break the remote connection?
  • Gleb
    34
    Hi , sorry missed the notification somehow.

    Sure, you can do so in the sandwich menu on the remote host side (the white one)
    lzr3v2lnmz4uydsu.png
  • Steve Wasiura
    0
    HI I experienced an issue in this version, when a connection was dropped, before it was dropped, i might have been typing too fast, and or holding down a key too long, and Win 7 pro 64bit activated a hot key for the shift. Then when an automatic re connection was made, I could not type anything, (ie there were no charters being displayed as i typed remotely. I could still use the mouse to click.. I tried to send a diagnostics report (239817), but of course my typing did not show up, so the ticket was blank.

    I self-solved this by using the on-screen keyboard, and clicking the SHIFT key on the on-screen kbrd, and then I was able to see what I was typing again.

    maybe you could use some icons on the floating control panel to show when caps lock is on?
  • Sergey N
    23
    Hello Steve,

    Thank you for pointing it out. We will investigate the issue and reproduce it in our test lab. And surely corresponding feature-request are already created.
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment

Welcome to MSP360 (CloudBerry) Forum!

Thank you for visiting! Please take a moment to register so that you can participate in the discussions!