• Leonardo Rodrigues
    I got some backup chains that were "locked" on my AWS S3 buckets using GFS configurations on the MSP360. That's working fine. Anyway, I got some backups chains that i'd like to remove, which of course I couldn't do via MSP360 as it complains backups were "locked". Fair enough.


    Using AWS S3 API calls, I removed the "ObjectLock" from the folders (prefixes on the S3 terminology), deleted them and, after some days, LifeCycle Policies on the bucket really purged the data. The data is really gone, it's not on the S3 bucket anymore.

    Question: How to get rid of the now inexistant backup chains on the msp360 dashboard? Consistency Checks only complains about stuff missing, while I was expecting it to see the data is really not on the S3 bucket anymore. "Refresh" also didn't help. Is there any way of getting rid of the backups chains on the MSP360 dashboard, given they really don't exist on the S3 bucket anymore? I really wasn't looking for emptying the bucket and starting from scratch ....


  • Alexander Negrash
    Have you tried to synchronise the repository?
  • Leonardo Rodrigues

    No, I hadn't .... tried it and nothing changed. Actually, judging by the ilustration on the "Synchronize Repository" screen, it seems it's more updating the repository from local files than doing a real two-way "sync". After clicking on "Sync Now", progress indicators shows "files being added" ... but I can't see any real sync for dropping the inexistant backup chains.

    Tried another test, which I hadn't done ... removed the S3 Storage Account, did a 'Database Shrink" (for maybe trying to get rid of any remaining local informations), readded the S3 Storage Account and adjusted Backup Plan to indicate that Storage Account again. It seems to have done the trick! Backups chains I purged from the S3 bucket are not shown anymore. Tried running the backup plan and despite an initial step I hadn't noticed on other backups (Deep Sync Restore Points), everything seems to be running smoothly, backup is running as Incremental (which clearly indicates MSP360 recognized the S3 data). I believe that will do the trick!



    Thanks Alexander!
  • Leonardo Rodrigues
    Hi Alexander ... it's me, once again, trying to continue on this thread.

    While sometimes removing and readding the S3 account seems to enough for msp360 not showing some backup chains I manually purged from the S3 bucket, as pointed on my previous screenshots, other times it doesn't seem to be enough, even I'm clearly seeing the backup chain is not on the S3 bucket anymore. If I point a complete new msp360 instance, on Restore-Only mode for example, the purged chain is really not shown. However, when trying to readd to the original msp360, even after shrinking database and everything else, in some cases the deleted chain insists on showing, and I can't have it to go away at all.

    Synchronizing Repository, as asked and tried, doesn't seem to change anything.

    Do you have any idea from where the backup chains information is coming from, if not from the S3 bucket itself? The chain is really gone, there's no traces on the bucket, but I can't get msp360 to stop showing it.

    I have also tried to completly delete the backup plan and recreating, but that seems to change some internal ID and completly new backups are started on the bucket, which is not what I'm looking for. So I believe that's not the direction (delete and recreate the backup plan itself)

    Would love some help on how to make msp360 not displaying already deleted, from the S3 bucket, backup chains!

    from S3 Browser, no GEN-00001 whatsoever
    removed S3 account, Shrink Repository Database, closed and reopened msp360 before readding the S3 account ... and the purged backup chain keeps showing!
    size on storage NOT AVAILABLE, the chain is not there, space can't be calculated, despite msp360 keeps showing it
    from another fresh MSP360 instance, on Restore-Only mode, only existent chains are really shown, maybe proving the information msp360 insists on showing is not coming from the S3 bucket, but from somewhere else
  • Alexander Negrash
    I will create an internal thread with one of our engineers for further investigation. Please DM you preferred contact email address
  • Leonardo Rodrigues
    sent my email address via messages here on the forum, should be in your INBOX
Add a Comment