• Glenn Curtis
    I have been accessing a remote PC for some months by selecting the Computer ID which has been retained in the RA dropdown list and then typing in the password to the PC.

    This has worked perfectly until today.

    This morning the remote PC seemed to have some issues (nothing to do with RA) so I decided to shut it down within Windows and RA disconnected.

    I waited a few minutes to try and access it again and this time RA was unable to connect to it remotely; I got a message when I tried to connect that it couldn't find the PC or PIN was wrong (I can't remember the exact message; sorry about that).

    I then remotely powered off the PC and tried again with the same result.

    I then accessed the PC using Teamviewer and discovered that it was working perfectly.

    When I looked at the RA screen however; I saw that the Computer ID and password had changed from what it was before. I had to be very quick in Teamviewer as I knew I would be disconnected before long.

    On my PC; I typed in the new Computer ID into RA and I was able to connect but I had to use the PIN and I was not given the opportunity to login using the PC's password that I had been previously using.

    Doing that RA worked as before.

    The big issue I have is that I don't know why the Computer ID changed. This is particularly worrying as the only way I could find out what it was was to do so via Teamviewer.

    It makes no difference to me regarding the PIN or password access as long as the PIN number doesn't change when the PC boots up next time.

    I really think that the Computer ID should never change.
  • Glenn Curtis
    This morning I tried to access the remote PC and although it worked I was only connected in "View" mode.

    Yesterday when accessing the PC it was also in View mode but at the time I had thought I must have accidentally switched it to View mode.

    This time, I looked at the default setting for the PC and it was set to View so I have changed it back to Full access.

    All these changes I had to make using Teamviewer.
  • Matt
    Have you tried using unattended access? That should solve your problems regarding Computer ID and PIN.
  • Glenn Curtis
    When I installed the software originally it had been set to use unattended access and had been working fine for several months.

    The problem only started yesterday as described above.

    I have just gone into the remote PC and found that the "unattended access" option was unticked. I have now set it to use unattended access. I had to make the change though using TeamViewer.

    I have tried to access the PC again and it still works the same way ie using the PIN but I guess this might change if I were to reboot the remote PC.
  • Sergey N
    Hello Glenn,

    Thank you for reporting this issue, may i ask you to clarify a bit:

    1) Was the software updated before the Unattended Access stopped working ?
    2) The PIN will definitely change as it is a dynamic kind of authorization
    3) May i ask you to set it up with the encryption key again and use UA with it.

    Thank you.
  • Glenn Curtis
    Hi Sergey

    No, the software was not updated recently (unless it did so without notifying me). I am running . I certainly haven't done an update. I believe the version has not changed since it was installed a couple of months ago.

    I have never set up an encryption key with RA.

    I just tried to access the remote machine using the ID I used last time. I got an error "Can't connect: looks like the remote computer is offline or ID is incorrect."

    Accessing the machine using Team viewer I opened up RA in it.

    It showed that the machine now had the ID that was used previously. I also checked how long the PC had been running and it was showing > 3 days.

    I tried to access the machine in RA by using that ID. It asked me for a PIN rather than user password which it had previously. I was able to connect using the PIN. Obviously this is not right because the PIN will change and I can't get the same functionality as when I connected via a password.

    Using TeamViewer I had a look at the settings and they are as follows:

    Default sound option set to muted
    Nothing else is set

    Incoming Connections
    Prevent incoming connections - unticked
    Default access level - Full control
    Prompt for incoming connection - unticked
    Allow LAN direct connection - ticked port 5975
    Allow internet direct connections ticked
    Close application - both setting unticked

    Encryption required - unticked
    Allow unattended access - ticked
    Pin length 4 digits
    Reset PIN each - unticked
  • Glenn Curtis
    I looked at the Install log held within C:\Program Files\CloudBerryLab\CloudBerry Remote Assistant and it is dated 22nd April 2019 when I initially installed the software and shows:

  • Glenn Curtis
    I rebooted the remote PC.

    Now when I access it remotely; I am being asked for a password rather than PIN.

    It is working fine but there is still the question of what has changed because I certainly haven't done anything different.
  • Jeffo2
    I too have the same issue. On another software they have the option of creating your own permanent pin or password that doesn't reset. Windows can do updates and restart computer. If this happens while you are away the pin on couldberry will reset and remote access will be lost. I suggest adding a user defined password or pin so that if a restart occurs you can still access the computer remotely.
  • Sergey N
    Hello Glenn and Jeffo,

    This is a really interesting case indeed, I myself use RA constantly and I have installed it numerous times with different builds and updated Windows of course and done everything a common user does with his PC. My ID is still the same, the issue you have encountered is an anomaly of sorts. We are currently investigating it from our side and will definitely provide a fix when we will pinpoint the reason of such behaviour. Thank you for pointing it out and sorry for any inconvenience caused.
  • Jeffo2
    My Id stays the same it is the pin that changes. If the pin changes how would you know what the new one would be if you are trying to access it remotely.
    The solution other companies use is that you are allowed to create your own custom pin (password). User name is not an issue.
  • Sergey N
    In this case simply use the Custome Password feature, which you can find in the Options - Security. It is a constant PIN of sorts.
Add a Comment