• Tom DeFrank
    I've been trying for 5 days now to restore to a local drive from amazon glacier. I've let it run and restarted it several times. One attempt I let it run over 48 hours and I keep having the same issue. The file count is stopping now at 0 out of 10002 files.

    One attempt yielded 2 out of 10000 files. That's something at least, but I have 271,362 files that I need to restore. By my calculation, at this rate, it will take just over 1,856 years you compete this restore. Unfortunately, my web and graphic design clients are not willing to wait that long.

    I created a support ticket through the app tools. I need to know how to resolve this.

  • Tom DeFrank
    Just received a reply saying I can't be assisted unless I purchase a maintenance license. This is not a maintenance issue. I am using the software properly. This is a technical issue that is not my responsibility to pay for. Or is it too much to assume that this software can restore the exact same data that's it's been backing up for the last 3 years?
  • David Gugick
    Tom, maintenance is for support and upgrades. Having said that, I've passed this message to the Support Team and someone should reply here.
  • David Gugick
    In the meantime, can you answer the following:
    1. Your CloudBerry / MSP360 Backup software version
    2. Whether you backed up directly to Amazon Glacier or you backed up to Amazon S3 and moved the data automatically to S3-Glacier using a Lifecycle Policy?
    3. If you used the Standard Retrieval type for restore (usually tales 3-5 hours for Amazon to get the data ready on average but it can take longer)
    4. Are you really restoring 271,362 files or is it just a subset you really need now?
  • Tom DeFrank
    Tom, maintenance is for support and upgrades. Having said that, I've passed this message to the Support Team and someone should reply here.David Gugick

    I understand and appreciate your help, David. Having said that, support and maintenance doesn't really sound like it would encompass application failure and bugs.

    1. I have the current version
    2. Directly to Amazon Glacier
    3. I've tried both Standard and Expedited
    4. I am restoring all of the files, we had a NAS fry..
  • Matt
    According to the log information you're currently running expedited restore. The Expedited retrieval option is not intended to be used to retrieve thousands of file. Currently I can suggest to recreate the restore plan, set retrieval rate to standard, and launch the plan then wait at least 10 hours.
  • Tom DeFrank
    Standard was the first option that I tried. It ran for over 48 hours and didn't download a single file. My issue that sounds similar to this:


    Last night I wrote a .NET script based off of Amazon docs and am doing expedited retrieval right now without issue through the CLI, but if possible I would like to get to the bottom of this issue because it much more convenient to have a GUI option. I'm sure you guys would like to figure it out too so others don't have the same problem so I'm willing to help troubleshoot. Is there anything else you'd like me to try?
  • Matt
    In that case we need to receive the logs right after you try using the standard retrieval rate. Please reference the existing ticket while doing that.

    In general, we currently don't recommend using "classic" Glacier, since it's much easier to restore data that way.
Add a Comment

Welcome to MSP360 (CloudBerry) Forum!

Thank you for visiting! Please take a moment to register so that you can participate in the discussions!