• Dave Moran
    0
    Firstly, huge thank you to those who’ve developed and made available this highly impressive tool. Bloody brilliant!!

    Here’s a newbie’s challenge.
    Givens: Client/Controlling PC is Windows 7; Host/Remote PC is Windows 10.
    After being powered off overnight, remote PC gets powered on (by an on-site attendant) and rests in its ‘Lock Screen’ status. When I try and access the remote PC, RA [Remote Assistant] returns the message, “Can’t connect: looks like remote computer is offline or ID is incorrect.” (Both ‘Allow unattended access’ and ‘Full control’ access level have been enabled on the remote PC.)
    (I note that at this stage the PC hasn’t progressed thru its Login Screen to subsequently launch the Desktop, and along with it Remote Assistant (which I have now added to the Startup folder).

    So, the question is, is there a way that RA can access a remote PC that has only just been powered up for the day and is at rest in its Lock Screen status?

    The work around that I have at the moment is to have a remote on-site attendant log in with the Windows account Password, wait for the Desktop to load and then for RA to auto-launch, and then text me the latest PIN.
    Curiously enough, in the scenario just described where after an overnight ‘powered off’ situation has occurred followed by a subsequent powered on Start-up and someone does the initial Login (and RA auto-launches), then when I attempt to connect to the remote PC, I am only provided with the option to ‘Connect with PIN’ and not with the option to ‘Connect with Password’! The latter would be preferable.

    If after successfully accessing the remote PC I then subsequently “Restart” it, then I am able to re-access it with RA, and in the process of doing that, I am provided with the option to ‘Connect with Password’.

    If however I Shut Down the remote PC and leave it for a say a couple of hours, then in trying to access it with RA after it has been powered back up, I’m again getting the message, “Can’t connect: looks like remote computer is offline or ID is incorrect.”

    This post seems pretty much the same as what Klaus Schulze posted about under ‘Remote Assistant as a service’ back on 1/24/2020.

    Cheers.
  • David Gugick
    107
    I haven't tried this to see if it works for RA, but it should be easy for you to test:

    • Run Task Scheduler
    • Create a Basic Task with a Trigger of "When the computer starts"
    • Start a Program
  • Dave Moran
    0
    Thanks David for your quick reply.
    Shall give your suggestion a whirl next week and see what damage I can do. (The next time I launch Task Scheduler will be my first. C'est la guerre!)
  • Dave Moran
    0
    Hi David,

    Have done the Task Scheduler bit and got mixed results. I eventually found within Task Scheduler Properties where to select “Run whether user is logged on or not”!
    However after an overnight Shut Down I’m not consistently getting access after the remote PC is Started-up in the mornings. I have read advice on the Forum about choosing ‘Run as Administrator’ with different things so I now figure that I should give that a whirl. Do I first need to clear out the task that I created a couple of days ago with Task Scheduler, and then select ‘Run as Administrator’ on RA, and then subsequently go back and re-create the task again? Or not?
  • David Gugick
    107
    To be honest, I am not sure. it's easy enough to recreate the task to have RA run as administrator, so I would just do it the hard way
  • Dave Moran
    0
    Some feedback.

    Have done the steps suggested re- ‘Run as administrator’ and used Task Scheduler to have RA launch ‘at system Startup’ (whether user is logged on or not) and the bottom line is I’m not getting the desired result of being able to access the remote PC after it has been powered up in the morning (subsequent to being shut down overnight) and it’s sitting in its Lock Screen state. The message that I get is, “Can’t connect: looks like remote computer is offline or ID is incorrect.”
    When I access the remote PC (either in person or via TeamViewer – have done both) and launch Task Manager, then I note that in the “Processes” tab RA is not showing up at all, though in the “Services” tab ‘Remote Assistant Service’ is shown as ‘Running’.

    If/when someone at the remote site does the Windows account login for me and then launches RA, then I can subsequently access that remote PC – but interestingly enough the only connecting option I get presented with is to ‘Connect with Pin’ – ie. the ‘Connect with Password’ option doesn’t appear. However, once I end up with access to the PC, and then subsequently do a ‘Re-Start’, then I am able to get a connection to the remote PC in its Lock Screen state (and proceed to logon). I note that after the ‘Re-Start’ when I’m connecting to the PC with RA, I now do get offered both the Connect with Password as well as the ‘Access using PIN’ options. Go figure.

    And that’s it – for this particular remote PC.
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment