• Roger Averdahl
    I was trying out a disaster scenario and tried to restore data to computer B that was created by computer A to my Backblaze account. I installed the Restore Only license of CBB on computer B since that made sense, restore only is what i want.

    But i could not restore anything and got errors but got two great tips from the support: The first was to make sure that the Backup prefix on computer B matches the one on computer A using the Advanced option for the backup storage account. The problem is that the only option i have is "Restore only". I cannot change the Backup prefix since that feature is dropped from that dialog:

    The other tip i got was to synchronize the repository. Brilliant, i had forgot about it so i went ahead to do that only to discover that this feature is non-present in the Restore Only version of CBB: Synchronize-Repository.png

    I had to switch the license from Restore Only to Freeware to activate those two features mentioned. But the question i have is, why is that? I was under the impression that the Restore Only was the one to use for restoration and do understand that all backup features are gone. But in reality restore features are gone as well.

    If this would have been for real, iow not a "restore drill", this would have been a catastrophe. I could in the end restore the files and do my tests when using the Freeware version instead of the Restore Only version.

    But my question still remains, why are some features that are critical for restoring from Backblaze removed from the Restore Only license of CBB? Why can´t i restore files from a Restore Only license?
  • David Gugick
    Are you saying you followed these directions, but did not get a list of computers to restore?

    What did was fine (using trial mode) but you should be presented with a list of computers on the backup target without any need to perform a sync.
  • Roger Averdahl
    Yes, that is what i tried. The first backup i did to my Backblaze bucket was an image backup and for those backups the Restore button never even works, in any "license-mode". So in the end i manually deleted all files from the bucket at Backblaze and created a file and folders backup.

    In CBB, The Advanced Settings dialog do never offer to change the Backup prefix in Restore Only mode. Since i first had made an image backup a couple of days earlier i needed to use the Repository Sync. I was and still is confused that both those vital options are lacking the Restore Only license.

    At first when i tried to restore the image backup and then later the file and folders backup i see the name of the computer, but i can never select any files though i have choosed to select them manually and not just Latest version, etc.

    And this last picture shows the confusion at CBB level as well, it don´t know what kind of backup i am trying to restore. (None fo the options worked...)

    I wonder how those things are released without that the QC notice those things.

    Looking forward to version 7 that hopefully has those basic issues worked out. :)
  • David Gugick

    If you are not seeing any backups listed, then we need you to check your B2 storage to confirm what you see in the cloud. You would normally see the cloud account in the list, with sub-folders for Images (if they were run) as well as drives that were backed up using file/folder, SQL Server database backups if you used that product, etc. Because you're not seeing anything, we need you to check your storage to verify if anything is there.

    Feel free to reply here with any updates.

    Can you also confirm the product version you are using?
  • Roger Averdahl
    I am using version on both computers. :)

    I could restore when i swithced license from Restore Only to Freeware version, so the issue here is not my B2 storage as restoring worked. The issue is that the necessary tools to "force" CBB to set the correct Backup prefix and use Repository Sync is lacking in the Restore Only version. Restore Only is interpreted by me that all necessary tools for restore are there.

    The reason behind my issue may have been that i day 1 did a Image backup that i could not restore at all. Day 3 i deleted the data manually from my B2 bucket and did a file and folders backup. That may have confused CBB since it may still expect an image backup rather than the file and folders backup. I did use the same bucket for both backups.

    If that was the reason, that me the end user messed up things when first doing an image backup and then deleted those files from the B2 storage and after that made a file and folders backup i still think that the tools to fix this, iow setting the correct Backup prefix and Repository Sync, must be aviable in the Restore Only version. If they had been there this thread would not exist.

    Have you tried to install a Restore Only license on computer X to do a restore of an individual file from a backup made by computer Y? :)
  • David Gugick
    Backup Prefixes are not needed in Restore Only Mode. The product scans for all computers backed up and let's you select what you want. In the case of deleting old backups, its best to do that from the Storage tab and not from the storage account directly. If you delete from B2, we don't know about the deletions and you'll need to Sync the repository. But you can have different backups in the bucket. As I mentioned in the previous post, backup types are broken up within the computer prefix in storage.

    I'll ask the team about why you were not seeing anything in storage until you switched license types.
  • Roger Averdahl
    I'll ask the team about why you were not seeing anything in storage until you switched license types.David Gugick
    What did they say? :)
  • David Gugick
    I did not hear back (and forgot to follow up with them). I'll ping them again. Sorry.
Add a Comment