• Roger Averdahl
    I have two computers. On my workstation i have a licensed version of CBB. On my laptop i have a trial of CBB that has expired and is now set to "restore-mode-only". So, i decided to test how restore works and discovered that it don´t work... Both versions are

    If i create a cloud backup, Advanced Mode, enable compression, enable encryption on my workstation that backup cannot be restored on my laptop. I use Backblaze B2 as my cloud provider.

    On my laptop i can see that the backup has been made when i create a new Storage Account linked to the correct Bucket at Backblaze B2 and that my workstation is named Z440 but i will not see any files. The repository feature is disabled on my laptop since CBB is set to "restore-mode-only". Don´t know if that has anything to do with it.

    If i now download all files from Backblaze B2 and un-zip all files to a folder everything seems to work until the restore started. It failed and complained that it could not find a file. The file can be found in Explorer so i wonder why CBB fail to see it.

    I want to like CBB but having tested different scenarios i have discovered that the weakest feature is Restore. Why is that on a backup application were restore is such a critical component?

    From the log:
    Type Plan Name File Size Result Start Time Finish Time Duration Message
    Unknown Restore plan on 2020-03-18 14:35:30 1 0 Failed 2020-03-18 14:37:40 2020-03-18 14:37:41 1 Det gick inte att hitta filen H:\00\ECBB_Z440\j4jhuqosi6j3ckocnvjonzvkuwir34p2q5i36ubo2cqcmbdjxksx3rimxicsb2g4pe4egchyhaew43u4qbhjbghngylrnrd3lgkicdak73gqdfk3bjbeah6ria64rue7e2vujzpa5l7i7bkg3at6mkn5kud5cvbrsjqldcr4a4lf4v4r5fia====.
  • Roger Averdahl
    I tried but on my laptop i cannot change the prefix. If i click on Advanced Settings the only option i have is Restore only.

  • David Gugick
    Are you saying that you don't get the Source selection page in the wizard that is shown in the article I referenced for Restore Only mode? If not, did you back up to a different bucket in storage?
  • Roger Averdahl
    I get the source selection but can only choose my workstation (Prefix: Z440) but do never get the option to choose any individual files in the backup and if i just choose to restore Z440 the restore fails as described abowe.

    Yes, i have tried to backup to different buckets. Both buckets were empty when i started.

    All backups are encrypted and i will try to backup some files un-encrypted. Will report back.

    FYI, during the trial period i had no problem with restoring files from my workstation (Prefix: Z440) to my laptop from Backblaze B2 though i used encrypted backups.
  • David Gugick

    If you used filename encryption on the backup, please refer to this KB article on how to resolve with Restore Only Mode.

  • Boris
    A small addition: it is not possible to see the files backed up with filename encryption in restore-only mode, the software must be running either a trial or a commercial version to perform the sync and display them. I've edited the KB article to stress that point.
  • Roger Averdahl

    I tried yesterday with non-encrypted backup and for those backuips restore works. It is not possible to restore encrypted backups. I hope this will be adressed i future versions of CBB.

    The help file states that to solve this, changing the backup prefix is the way to go, but in "restore-only-mode" i cannot change the backup prefix. The picture below is from the help file but all i get is the Restore only option with no option to change the backup prefix.

Add a Comment