• Steven Newstead
    0
    Hello we have suffered a ransomware attack and most of my backups are out of action. I have a backup created with Cloudberry Backup to an Amazon S3 storage. I am just trying to copy some files back from these storage using Cloudberry S3 Explorer Pro but it is giving me an error of 'The decryption password is incorrect.' however I am pretty sure these were created without any encryption enabled. Any ideas, thank you in advance.
  • David Gugick
    84
    A few things you need to understand about how explorer works with CloudBerry backup files. First, explorer will automatically detect that the files were backed up with the backup product, and will automatically try to restore them when you perform the copy operation. Therefore, if the backup was encrypted you will need to make sure you have the correct encryption password set up in the options screen in the product. If the backup was not encrypted, and you have an encryption password set, then it may be trying to decrypt the files when they are in fact not encrypted. So check your options and see what’s set. But know it’s not a copy operation and a restore that’s happening. Is there a reason you want to copy the backup files versus restoring them with CloudBerry Backup?
  • Steven Newstead
    0
    Hi David thank you for your reply. It was just to try and get a few vital files back. Even though I didn’t think I had encryption set on the backups neither Cloudberry Backup or Cloudberry Explorer would work. They would see the files in the S3 storage but then give the error when restoring via Cloudberry Backup or copying back via Cloudberry Explorer.
    I have now managed to restore from an old backup the Cloudberry Explorer and Backup program files. This has allowed me to copy certain vital files back from the S3 storage using Cloudberry Explorer however the Cloudberry Backup doesn’t want to restore properly giving my a decryption error again.
  • David Gugick
    84
    If Backup is prompting for an encryption password, then encryption was used during the backup. If you are certain no encryption was used for backup, then I'd recommend you open a support case to have the team investigate further.
  • Steven Newstead
    0
    Hello David

    I am slowly getting a bit of our system restored but why can I see more up to date files/directories online in our Amazon storage through Cloudberry Explorer Pro than what I am able to see view / restore via the Cloudberry Backup for MS Exhange. I need to get these files back onto my server what is the best way if I can’t see them from Cloudberry Backup. I don’t want to have to download them one at a time using Cloudberry Explorer Pro.

    Regards

    Steven Newstead
  • David Gugick
    84
    You can synchronize the repository, if you think something happened that caused the client to be out of sync with the backups in the cloud. Are you restoring from the same computer that performed the backup?

    https://mspbackups.com/AP/Help/backup-and-restore/about-backup/repository-synchronization
  • Steven Newstead
    0
    Hello David yes I was trying to restore to the same server that created the backups in the first place. I have the Cloudberry Backup for MS Exchange and Cloudberry Explorer Pro on the same server. I can view numerous multiple later versions of the files on the Amazon S3 Storage through the Explorer but I can not see these later files through the Restore function in the Cloudberry MS Exchange.

    I have now managed to pull most of these files back onto the server by painstakingly using the Cloudberry Explorer and copying them one by one.
  • David Gugick
    84
    So, you are saying when you tried the restore and selected that you wanted to manually select files, you were not prompted with a list of files in the treeview control with a list of backed up versions under each? If so, the repository probably got out of sync. I'd recommend you open a support case to have the team figure out what happened and how best to remedy the problem.
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment

Welcome to MSP360 (CloudBerry) Forum!

Thank you for visiting! Please take a moment to register so that you can participate in the discussions!