• David Leitch
    0
    Hi Newbie to cloudberry drive here.

    I want to save excel PublishObjects to AWS S3. When I use Excel PublishObjects to C drive it works fine. When I use Excel PublishObjects to AWS S3 using a CloudberryDrive path the resulting HTTP response header says content type is Octet stream instead of HTML and the macro crashes. When Excel publishes the object to my local C drive and then I copy that directory to S3 using the file manager the HTML file has the correct HTML content type in its header when served.
  • Sergey N
    26
    Hello David,

    The simplest solution here would be perhaps using Upload Rules that will set the correct headers for the files in question. Please keep us posted regarding the results.
  • Sergey N
    26
    Hello David,

    The simplest solution here would be perhaps using Upload Rules that will set the correct headers for the files in question. Please keep us posted regarding the results.
  • David Leitch
    0
    Uh. I don't suppose you have an upload rule? I guess I would use the CLI and the rule would be of the form

    If suffix = .html then content type = html ??

    I'm going to get a license anyway
  • David Leitch
    0
    Hi. I asked about this issue over in Stackoverflow, and the comment from an independent certified amazon developer was that the problem is likely to to do with Cloudberry as Amazon won't change the type.

    https://stackoverflow.com/questions/55979474/why-do-excel-published-static-html-files-have-content-type-octet-on-amazon-s3
  • Sergey N
    26


    That is correct, so you basically set it to the content type you are interested in and it should assign it properly. Now regarding changing it to octet i presume it is happening due to the way driver handles the files. We take a closer look at this issue with our R&D.
  • David Leitch
    0
    So I tried setting an upload rule from the "Managed Drive Options" . The rule sets uploaded files with suffix . html to be type text/html. However it doesn't change anything. I guess writing to a file on S3 from within Excel isn't seen as an upload.
  • Steven2131
    0
    Did you find a solution to this? Having the same problem. The upload rules seems to work when creating a new file. But if it's editing an existing file it seems to override text/html with application/octet-stream
  • David Gugick
    108
    You should be able to create a rule for this within the product. The issue with rules was addressed with the 180 version sometime ago. Can you verify what version you're running and if there was a reboot after the upgrade to 1.8? Also check your rules because if there are multiple rules for that file type, then only the first rule is applied on upload.
  • Steven2131
    0
    Thanks David. Yes that seems to have done the trick. My first rule where I was trying to apply it to only html files didn't seem to work. But the 2nd rule applying to all files when I was testing wasn't being applied.
  • Marktb
    0
    We are having the same/similar issue. We just recently upgraded to 3.2.0.2 and seemed to break our rule.
  • David Gugick
    108
    See my comment above. Make sure you don't have duplicate rules.
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment