• Ann Bouchard
    I am attempting to back up a folder that is on a TrueCrypt partition. The backup plan always gives the following error:
    VSS Error (Code: 2416) KB10070
    An error occurred while calling a routine on a Shadow Copy Provider. Event ID: 12293

    The Windows event log reveals:
    IVssSnapshotProvider::IsVolumeSupported() failed with 0x8000ffff [hr = 0x8000ffff, Catastrophic failure

    After some research, I discovered that TrueCrypt does not support VSS. It is my understanding that VSS is used to back up files that may be open and in use while the backup is occurring. I can ensure that the files in this folder will never be open during a backup, so I'd like to just turn off VSS altogether for this backup plan.

    I attempted to do so by unchecking the "Force using VSS (Volume Shadow Copy Service)" checkbox on the Advanced Options page of the Edit Backup Plan Wizard. However, when I run the backup plan, it still has a stage that says "Creating a VSS snapshot", and then the backup plan fails with the same VSS error. Then, when I go back through the wizard, when I get to the Advanced Options page, the "Force using VSS" checkbox is checked again (all other settings in the wizard remain as I have set them; only this checkbox is altered from my setting). It's as if MSP360 is refusing to accept the unchecking of that box.

    So, my questions are:
    (1) Should unchecking the "Force using VSS" disable VSS, as I desire? If not, how do I disable VSS for this backup plan?
    (2) If this checkbox will not be unchecked, is that a bug that I should report? Or is there some other setting that has to be set correctly in order for that checkbox to be unchecked?

    Many thanks.
  • Alexander Negrash
    Sorry for the delayed response. This is a known bug and is going to be fixed in one of the upcoming bugfix releases.
Add a Comment