• Wissam
    I would like to start by saying that this was never the issue I had with AWS but when it comes to Wasabi, even though I was able to successfully mount the drive, I was not able to access it. The Volume drive gave me the error message saying that "W : / is not accessible. Incorrect Function".

    I am fairly new to Wasabi but I'm sure it has to do with the policy issues however I'm struggling to find any basic guidelines to set it up. I've attached the "AmazonS3FullAccess" on my user because that was something I was familiar with AWS however it didn't work and I've also tried other policies like "AdministratorAccess" "WasabiFullAccess" "WasabiAdministratorAccess" and "AmazonS3FullAccess" none of which worked as well.

    I used both account for Root and IAM access keys and secret keys as well and now I'm hitting the road block. Please help me out what I did wrong.
  • Bill B
    I'm working with this Cloudberry/Wasabi combo for 3+ years now... it's working fine for me. Here's how to set it up:

    1.) In Wasabi, create a New Bucket (you'll dedicate for this purpose). All lowercase, looks like they allow ~20 characters. Create a meaningful name (I choose "bb2405-zBook2405");

    2.) In Wasabi, create a New User, Upper & lower case allowed, ~20 characters, Access Type Programmatic/API (my new user was "Cloudberry-zBook2405" - use something like this meaningful to yourself), for permissions select "WasabiFullAccess". Usually at this stage the process will then automatically create an Access Key for this new user (and display it to you to download)... if this happens you can skip step 3, if it doesn't happen you have to do step 3 for this new user;

    3.) In Wasabi, create a New Access Key for the sub-user created above (note the Access Key value and the Secret Key Value that will only be displayed once);

    4.) In Cloudberry Drive main screen select Add, then in the top field "Storage Account" pull down to see the option "<create a new account>"; In the top field "Storage Provider", hit the pull down and scroll down to select the Wasabi option;

    5.) In this Wasabi setup screen, choose a display name (this will show as your cloud mount point via your desktop OS - I named mine "bb.wasabi"); Fill in your access key & Secret key from the previous steps;

    6.) Next screen, if it's not automatically mapped into the "Storage Account" field, select the Wasabi account we created above (my "bb.wasabi"); select a local drive letter to mount it to, Volume label you're allowed ~11 characters (in Win11 world here), for path hit the three dot menu pop-up and select the shown new Wasabi Bucket you created up in Step #1. You probably want to "Mount this account as virtual disk at system startup" and mount it as a "Networked Mapped Drive".

    After all this everything should be working for you. In your earlier reported case, it's possible you left out one of these steps. If you still get stuck doing anything here... gimme a holla!

  • Rickman
    I'm having the exact same problem as this. Have followed the same setup as Bill B mentions above but get the same error when trying to access the mapped drive created by the software.

    Did you ever manage to get this resolved? This would be great software for us, but there's no way I'm buying it if it doesn't work correctly.
Add a Comment