• Beebes
    I used the free (demo) version of Cloudberry Windows Desktop to do a full backup of a Windows 7 PC to a local USB drive. I used the same Cloudberry version (in restore-only mode) to restore all the backed up files to a new Windows 10 Professional (64-bit) PC. That process was successful, and I saw no problems.

    On 3/12/18, I upgraded Cloudberry on my Windows 10 PC to the paid Backup Desktop Edition, with annual maintenance. I want to continue using this Cloudberry version on the same Windows 10 PC to do backups and restores, still using the same local USB drive.

    I'll keep all the backup files from Windows 7 on the USB drive in case I need to recover them again in the future. For new Windows 10 backups, I do *not* want to continue using the backup or restore plans I used with Windows 7. I want to start fresh with new backup and restore plans that use a new backup storage account (folder) on my USB drive.

    To test Cloudberry on Windows 10, I created a new backup plan that backs up one file to my USB drive. The backup plan runs successfully, with no errors. I can't create a restore plan that works though. When attempting to restore, I get the error:

    Access to the path 'C:\Users\Beebes\Documents\Finance\Statements and Transaction Records\TempFiles\Backup Restore Target\TestFile.pdf' is denied.

    Log files show other info that may be relevant, for example:

    2018-03-17 09:51:57,493 [Base] [1] WARN - Unknown .net version: 461308
    2018-03-17 09:51:57,765 [SERV] [1] INFO - Backup destination: /BUNCHAN
    2018-03-17 09:51:58,182 [CL] [8] ERROR - Command::Run failed:
    2018-03-17 09:51:58,189 [PL] [8] ERROR - Error occurred on restore
    2018-03-17 09:06:21,360 [PL] [Initialization] ERROR - Service path is null. Service name: LSM
    2018-03-17 09:06:21,360 [PL] [Initialization] ERROR - Service path is null. Service name: NetSetupSvc
    2018-03-17 09:06:22,032 [Base] [Initialization] ERROR - Cannot find AD service enpoint
    The local computer is not joined to a domain or the domain cannot be contacted.
    at System.DirectoryServices.ActiveDirectory.Domain.GetComputerDomain()
    at UU.D(String )

    The backup destination "/BUNCHAN" looks wrong for my Windows 10 PC -- it's the name of my old Windows 7 PC. I don't know how to correct that error though.

    There may be additional configuration errors I need to correct.

    Can someone help me diagnose and correct the restore problem?
  • MSP360
    It may be best to create a support ticket with the full logs. If you go to Tools\Diagnostics you can submit a ticket that includes all logs.
  • Matt

    Regarding your issue.

    1. The error you're seeing during restore is related to NTFS permissions.
    Please start Backup Service under administrator account: go to Tools > Change Service Account, enter local administrator account name and password, click OK. The service will be restarted automatically.

    It is generally recommended to use local administrator's account name because domain administrator is not always a local admin on the host machine.

    Learn more: Backup for Windows - Backup Service explained.

    2. AD warning messages can be ignored, they are irrelevant in this case.

    3. Regarding the backup prefix(computer name): you can change it by editing your storage account and going to "advanced options" menu. There you can choose computer name. This is used to identify your data on storage.

    So to fix the issue you just need to solve the permissions problem by making sure the software uses account that has full access to the files and folders, and then select your preferred backup prefix.
  • Beebes

    Thanks so much for your response to my question. I confirmed that restarting the Backup Service under the Admin account fixes the errors I saw. And I now see where to select the backup prefix.

    On my old Windows 7 PC, I had the Backup Service running under the BackupOperator account, which I created and made a member of the Backup Operators group. For full backups, that seemed to work better than running under the Admin account. Admin was prevented from accessing a few files that BackupOperator was allowed to back up.

    I tried to use the same setup on Windows 10 -- I created the BackupOperator account, made it a member of the Backup Operators group, and restarted the Backup Service under the BackupOperator account. With that configuration on Windows 10, CloudBerry gives me the "Access to path is denied" error during restore operations. I think I've skipped something in the setup, but I don't know what it is. When I look at the CloudBerryBackup service information in Task Manager, the Group column is blank.

    Do you recommend using an account in the Backup Operators group for the Backup Service? If so, can you tell me what I need to do to make it work?

    If it's more appropriate I'll submit a support ticket for this question, with logs.

  • Matt
    To actually use backup operator after that account is added to backup operators group you need to make sure the option "use backup operator" is selected when creating/editing the plan.
  • Beebes

    I have "use backup operator" selected in the backup plan (Advanced Options page in the Backup Plan Wizard). With the CloudBerry Backup Service running under my BackupOperator account, the backup plan runs with no errors.

    I create a restore plan to recover the file I just backed up. I leave the Backup Service unchanged, so it's still running under the BackupOperator account. When I run the restore plan, it shows the "Access to the path is denied" error.

    I then change the Backup Service to use the Admin account, restart the restore plan, and it runs without error.

    Is there a separate option somewhere to use backup operator during restore? Or should I not try to run the Backup Service under BackupOperator during restore?
  • Matt
    Is the backup operator user an admin on that machine or just a regular user?
    This seems to be related to Windows UAC limitations. Even during system state restore user folders(and you seem to be restoring that file to one) can appear empty due to permission issues despite backup operator being used.

    Restoring to any other folder should work fine.

    If the backup operator user is not an admin I suggest to simply add administrator account to backup operators group.
    You can also modify permissions for that user folder manually.

    If that still fails or the original backup operator is already an admin then we definitely need to see the logs and maybe even discuss this with our devs.
  • Beebes
    I think you've solved my problem.

    My BackupOperator account was a member of the Backup Operators group but not the Administrators group. I added BackupOperator to the Administrators group, and now I get no errors -- either during backup or restore -- when the CloudBerry Backup Service is running under the BackupOperator account.

    I could try a variation of this configuration: Instead of adding my newly created BackupOperator account to both the Administrators and Backup Operators groups (and running the Backup Service under BackupOperator), I could instead add the predefined Windows Admin account to the Backup Operators group, and run the Backup Service under Admin. Is one of these approaches better than the other?

    In any case, I think I'm ready to start using Cloudberry regularly for backups.

    I appreciate your help and your patience. Some or all of my questions might be answered in existing CloudBerry documentation or in the forums, but I had some trouble determining what my mistakes were. Thanks for pointing me in the right direction.
Add a Comment