• zefoto
    Hi. I don’t know if somebody came across this issue and found out a solution. I run CloudBerry Backup Desktop 2.4 on Mac OS X 10.11 (El Capitan) and one of my backup plan is backing from a source on an external USB HDD, to a destination that is another external USB HDD. I have issues with the scheduled backups for this plan. For the moment I have scheduled automated backups every 24 hours. My Mac is not always on, so most of the time the 24 hr timer times out while the Mac is powered off. So when I power on, CBB tries to do the backup. The issue is that CBB kicks in too early. As soon as the Mac has booted, before I even had a chance to log in a user session, CBB tries to do the backup. By at that time the external HDDs are not yet mounted resulting in CBB failing. Is their a way to configure CBB so that it waits for the HDDs to be mounted before trying to do the backup? Or at least waits for some fixed time? I would be interested in any workaround that you may have found. Thanks.
  • Robert Techhead
    Hey there, zefoto!

    You can instruct macOS to automatically mount hard drives upon bootup by executing the following command in terminal:

    sudo defaults write /Library/Preferences/SystemConfiguration/autodiskmount AutomountDisksWithoutUserLogin true

    Let me know if it helped!
  • zefoto
    Thanks Robert for the hint. I will try this.

    However I am just curious if there is any security risks in automounting the disks without user login?
  • Gleb
    , not really. It still takes a user to access any file including the automounted drive
  • zefoto
    Hi. Just want to provide an update on this. Unfortunately the proposed solution did not solve the issue. Everytime CBB schedule times out while the mac is powered off, I get an error message seconds after booting up the mac: "Error: Some items not found Directory not exist".

    Here are extracts from log files where CBB cannot find both source nor destination folders (both are external USB HDD):
    2018-04-25 06:34:17,638951 [ERROR]: [ CBB ] [ 5 ] Specified path does not exist: /Volumes/MesFotos
    2018-04-25 06:34:18,743601 [ERROR]: [ CBC ] [ 10 ] Directory not exist: QUrl(file:///Volumes/VroumVroum/Sauvegarde CBB)

    I checked if the defaults command worked correctly and apparently it did:
    defaults read /Library/Preferences/SystemConfiguration/autodiskmount
    AutomountDisksWithoutUserLogin = true;

    When the CBB schedule times out while the mac is powered on or when I trigger the backup manually, backups are successful.

    Any hints to solve this would be appreciated. Thanks for the help.
Add a Comment