• Sergey N
    We are excited to announce the release of version 2.3 of MSP360 Remote Assistant, with new performance and usability improvements and awesome new features.

    Multi-Monitor Mode

    We have implemented the ability to view multiple monitors at once. Now you are finally free to utilize that 4K monitor of yours. The same view is available for Meeting mode also.

    CMD and PowerShell Mode

    Because sometimes you don’t even need to see the application GUI, we’ve implemented this awesome mode, in which you can use your CMD or PowerShell tools directly from Remote Assistant. Don’t forget to execute the Remote Assistant service from an account with appropriate permissions to get the job done.

    Address Book

    This is one of the most requested features from our customers. At the moment it is limited to five records. Your Recent List is also automatically imported and added to the Address Book. However, bear in mind that if you delete it from the Address Book, you won't be able to add it back afterward.

    Custom Password rework

    From now on, you can use the Custom Password feature along with unattended access without the need to use the encryption key. We know that this is sometimes more comfortable than using the encryption key, but please don’t forget about security. We still recommend using the encryption key on the most important machines.

    Screen Scaling and DPI Calculation Improvements

    This is a really important feature, which should drastically improve the scaling and support of non-standard resolutions. From this version onwards, view settings are saved correctly, including picture quality, Windows interface, and wallpaper settings.

    Important Under-The-Hood Changes

    We have also redesigned our server structure and rewritten parts of the network and server code to improve the speed and stability of the connection. The GUI has also had a bit of change; check out the new Options menu.

    As always, we are really eager to hear your feedback and will be really glad if you reach out to us via all the available communication methods. Thank you.
  • Sergey N
    Hey there Daniel,

    I replied to you in the e-mail, but for other our customers I should mention that the Menu is located in the Display Switch section. Thank you for bringing it up.
  • Aurum
    Hi, I have a few observations:
    - Meeting: It would be cool to be able to invite known contacts in the "Participants" panel, that are in the "Contacts" list.
    - I've 3 monitors of which I shared the "2" (left) while "3" (middle" is the main. The mouse is only visible in the shared session if it is in the main window. It's not a big problem, just funny.
    - Exporting the "contacts" to be able to use the list on another workstation, would be neat.
    - Longer "Contacts" list would be even more neat. 8)
    - Unattended access is not really unattended if it requires a pin. Protecting the users session is fine, but making this optional would be practical.
    Thank you.
  • Sergey N

    Thank you for suggesting those features, I will discuss it with our R&D and some of them might get on the development roadmap.
  • Aurum

    - I have observed RA seemingly dislike wifi connections, wired performs much better
    - In some instances RA loses connection without noticing it, it just stops functioning until a manual reconnect
    - In some cases mouse clicks aren't going through, however in the affected window the mouse roller was working - in the meantime, in another window everything works. The affected window is unclickabe anywhere, header included.
    - In one case (RA started by a user-level coworker) the elevated prompt for password was not writable through RA session (considered normal operation?)
    - User account switching is not handled (W10), requires manual reconnect

    Thanks and Keep up the good work!
  • PaulFB
    So I'm looking at an alternative to TeamViewer and came across MSP360. I downloaded it and installed it on 2 computers to test. I have a problem that when I connect to the remote computer I cannot see the actual web page when I open a browser. I've tried Chrome, Edge and Internet Explorer 11. Its just a blank page. The remote notebook as an older HP 17.3" with a resolution of 1600x900. I had a similar problem with TeamViewer years ago but they have sorted that problem out. Any ideas?
  • Spires
    So, was running fine on Win10. I used the check for updates button - it downloaded, uninstalled 2.2 and installed 2.3 - then nothing. Tried opening the app, got a message saying "It's already running." Closed the app in Task Manager, relaunched. Nothing. Tried opening the app again and got the "It's already running" message again. Uninstalled. Downloaded 2.3 from the website. Installed. Same results.

    I had the 2.2 install file still, so I uninstalled 2.3 and reinstalled 2.2 and all is fine. Any thoughts on why 2.3 won't open??
  • Sergey N
    Hello Paul,

    This is a really interesting issue indeed. Never encountered it before so we would need some Diagnostic Info from both of the machines to take a look. Please send them to us via Main Menu - Diagnostic and please mention this thread in the description. Thank you.

    Hello Spires,

    It seems that the Remote Assitant Service wasn't removed correctly, this usually might happen if there were not enough permissions for the installer to reach it. I would suggest trying to remove it manually via services.msc and re-installing the 2.3 running it from an elevated Admin account.
  • Ficko
    I am a first time user.

    Managing computers with user(s) and one admin account.
    It is set up such a way, that I can log into the admin account without distracting the user(s).

    It works fine with AnyDesk, Windows RDP, TeamViewer.

    However Remote Assistant kicks off the users if I am trying to log into the admin account.

    Any work around?
    To give specific user and passwords before connection being made and not locking the sessions?
    Maybe on cmd line?
  • Haitham Alskiber
    Update required on my iPad app?!
    I can't remotely access because every time i need to connect it shows me that i'm runnig an old version which need to be update but when i check for an update there's nothing! And I’m sure that I was downloaded the latest version.

    There’s an attachment showing the problem. pskynze5ivbnep9z.png
  • David Gugick
    That issues seems to have been fixed in version 1.1.1, which is the version I am seeing on the AppStore (available since March 11).

    Please check the AppStore in your region and report back what version is available for download.

    You may also want to try removing the app and re-downloading.

    If all else fails, let me know and I'll reach out the dev team.
  • Haitham Alskiber
    @David Gugick
    I’m still having the same issue!
    Even i did download it from another App Store region *USA*.

    Is the issue of update also may include the PC version?
    My PC version is 2.3
  • Jason Huston
    I'm having trouble connecting my Windows 10 based PC to a client laptop is it possible using this software to control a Mac OS based computer with a windows based computer If So what are the steps on the client machine
  • David Gugick
    You can control PCs from the Mac, but controlling a Mac from another computer is not supported yet. That feature will be released later this year.
  • David Gugick
    I'm closing this discussion. If you have any questions / issues with Remote Assistant, please start a new discussion for better tracking by the MSP360 team. Thanks.