• AlexSeidel
    Dear All,

    I just upgraded RemoteAssistant from v2.2.0.51 to v2.3.0.52. This was done first on my PC then on the remote machine which runs in unattended mode. I have done this a few times before but after this upgrade I am a bit worried because the remote machine doesn't show the option for "Check for Updates" anymore. So I fear there will be a problem when the next version comes out. For comparison this is the menu which is shown on the remote unattended machine with the current version:


    Whereas the previous versions showed this menu with the option to update:


    Is the change intentional or am I missing something? The ability of updating an unattended machine without physical access is important.

    Let me thank you for this wonderful software and keeping it free as well!!!

    I am looking forward for the upcoming multi-connection support, which I think, will also avoid the irritating warning message "...user is already working on Remote computer. Your connection will pause...". I hope so ;-)

    cloudberry_v2.3.0.52_options (8K)
    cloudberry_v2.2.0.51_options (10K)
  • Sergey N
    Hello Alex,

    Thank you again for noticing it, already discussing it with R&D.
  • Jared Pickerell - DCEduCoop

    Noticing that when remoted into 2.4 machine, the "Check for Updates" is still not there in the Remote Desktop menu on the remote machine, same as @AlexSeidel said was the case in release 2.3.

    I have noticed this being a problem with not being able to remotely update some of my machines. On a couple of them, I still luckily happened to have a copy of another party's remote support app and was able to get Remote Desktop client updated within the other app's 5 minute connection timelimit.

    Would really really love to see remote update capability brought back in a 2.4 patch or when 2.5 get released. Makes is quite hard to not be able to remotely update those machines on 2.3 and 2.4.

    FYI, do absolutely LOVE the multi-connect support that we got in version 2.4!!!

  • AlexSeidel

    Interestingly there is a workaround for this problem. I did this several times and it worked, at least for me, no guarantee, whatsoever! ;-)

    There is no client update option in the menu but you can update the remote client manually as a normal installation while beeing connected! I thought that I will lose all connection somewhere in the middle of the installation process but it did not! I started the installation by clicking on the file and it asks if I will close the application as it is currently running. Yes, and the connection is gone. Don't worry, simply reconnect and you can proceed the same way as if it is done on your own machine. As I remember you will have to reconnect twice. Don't panic, the last reconnect will, if done too fast, first show that the host is not running or has a different ID but a few moments later it will reconnect and show the updated version number.

    I was surprised that it runs so smoothly. It would be better to have the option again in the menu but in the meantime it is ok for me. Maybe one caveat to consider: The user running the update on my remote machine has admin rights so the system is not asking for an admin password to gain necessary rights. Maybe this could be different if this user doesn't have sufficient rights in the beginning. I have not tried this case. So don't blame me if your installation is stalled when trying to gain elevated rights and it get's no confirmation.

    Good luck!

  • AlexSeidel
    As an addendum to my previous post I revisited the remote installation process and can say that it works also for remote users not beeing admins and you will get the UAC password prompt so you can enter the required admin password to proceed with the installation.

Add a Comment