• Olivian Stoica
    0
    I and a part of my team use CloudBerry Explorer to uploaded images and videos on our S3 Amazon server that we use on our site. We're using the freeware version.

    The way we use it is that we've connected the app to our server through the private key, etc. Next, whenever we have to upload a file, we just drag and drop it into the app or from a Windows folder in our S3 bucket.

    This went OK until some months ago when I noticed that the images and videos are uploaded with the following HTTP Content-type head: binary/octet-stream. This may prevent Google from crawling and indexing the files.

    Moreoever, the Cache-control value is wrong: "maxage" instead of "max-age".

    From what I've found in the app with the help of a developer colleague (I'm not a developer), these two HTTP headers are "user defined":
    Content-type
    Cache-control

    To note, I can manually update these HTTP headers by right-clicking the files in the app. However, I was hoping to fix this issue.

    My colleague tried finding the issue on our side, no luck so far. Could this problem be related to CloudBerry?

    I believe it has something to do with the way the files are read.

    We've uploaded these extensions: GIF, PNG, JPG, MP4

    The extensions are also defined in the Extensions' List in CloudBerry.
  • Boris
    0
    Hi Olivian,
    Are you using the latest version of Explorer?
    I've just checked this in 5.9.1.192 version and the headers are set correctly for at least png and mp4 files as image/png and video/mp4 respectively.
    Please go to Tools > Http headers in the software and take a look at Cache-Control and Content-Type values. Are image/png and video/mp4 values present for Content-Type?
  • Olivian Stoica
    0
    Hi Boris,

    I'm using version 5.9.3.5
    As for the content-type values, the extensions are already there. Could I revert to the version you mentioned? I would try it and see how it goes. Thanks.
  • Olivian Stoica
    0
    Tried replying a few days back but it didn't go through. I have version 5.9.3.5 and checked the settings as instructed in Http headers. The values are present there. Should I revert to version 5.9.1.192 and see if it works?
  • Ann
    0
    FWIW, I use CloudBerry Explorer v5.6.1.8 on Windows 10 and it uploads with correct Content-Type.
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment

Welcome to MSP360 (CloudBerry) Forum!

Thank you for visiting! Please take a moment to register so that you can participate in the discussions!