• Patrick Hisshion
    0
    Reporting a behavior that has no error (logging set to high).

    Cloudberry Explorer for Amazon s3: Build 6.0.0.10

    Action: "Copy"
    Source: OneDrive folder\<file set to "Available when online">
    Destination: S3 Bucket

    Result: Nothing is copied and no error in the Cloudberry interface or inside the Cloudberry log file.

    Workaround: Setting the file or folder to "Always keep on this device" allows Cloudberry to copy the file.

    Note: The "Move" action works.
  • David Gugick
    99
    I think that makes sense given that onedrive is a cloud-based storage service with some locally cached data and pointers to the cloud data. If the file is not persisted locally, then there would be nothing to copy to S3.
  • Patrick Hisshion
    0
    Hi David,

    Is there a way to force Cloudberry to download the file locally to then copy into the bucket?

    When I use "aws s3api put-object" on a ALOUM object, it downloads the file onto the device then is able to transfer it.
  • David Gugick
    99
    Not that I'm aware of. Normally I would just suggest you use our Office 365 product to back up data in OneDrive. I'll do a little more digging this afternoon see if I can find a solution for you, but right now I don't know of any.
  • David Gugick
    99
    Can you explain what an ALOUM object is? I was not sure, tried Goggling and found nothing.

    Doing a little research, I do not see an issue with backing up the local OneDrive folder.

    I think you'll need to keep your Setting to "Always keep on this device" if that addresses the issue.
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment