• JohnElliott
    1
    The Host computer is running Windows 10 64 bit and the client computer is running Windows 7 32 bit. When i paste the Public key from the Host to the Client an error message appears 'Public key must be a base64 string. What do I need to do?
  • David Gugick
    67
    That message usually indicates they key has an extra (accidental) character in it somewhere. Make sure the previous key is deleted and the new one pasted without any leading or trailing spaces.
  • JohnElliott
    1
    Thanks for that, the key now works. However, the Host computer is setup for unattended access with encryption, but the client computer is still asking for a PIN number when I connect to it
  • David Gugick
    67
    Are you sure you enabled unattended mode on the correct computer? This should be done on the Client (target) and not the Host (source).
  • HarryB
    13
    Please check that you pasted the encryption key from the host to the client. In order to do that please type in the ID of the remote PC and press the "Lock" button, paste the key in this new pop-up window and give it a try. Please let me know if this doesn't help.
  • Allan
    1
    I have just installed the software on 3 local Windows 10 computers. Two of them have unattended access enabled and I can access one OK. When accessing the other one I keep getting the error "Public key must be a base64 string". This happens when I copy and paste or Read it from the file. I have ensured there are no training or starting blanks in the key and the previous key has been erased before pasting. I have created different keys on the remote computer and each time I still get the error.

    Please advise how this can be resolved.
  • HarryB
    13
    Hi ,

    Could you send me a couple of screenshots of the initial encryption key and how you paste it?

    Thanks in advance.
  • Allan
    1
    I will be away for about 4 days so I won't be able to respond to any thoughts / actions till then.

    As mentioned in my post, I have also used the "Read it from file" option as well with the same result on several different key files generated by the Target computer.
    Thanks for your quick reply.
    Attachments
    After OK pressed (30K)
    Before key pasted (12K)
    Key highligted before paste (64K)
    Key pasted (21K)
    Text key to be pasted (61K)
  • Allan
    1
    Here is the key file also - I will now change the key on the Target computer.
    Attachment
    ra-key-TLCCSECRETARY.txt (2K)
  • HarryB
    13
    Your key doesn't work for me indeed, however the ones I generate are fine, so we will need some more information to investigate this issue. Could you please send us the diagnostic logs from both the machines in question by going to the main menu button and choosing "Diagnostic", use "Send to Support" button there. The logs will be sent to our support team automatically. This will help us diagnose and troubleshoot the issue. Please add "Logs for Harry from Allan" to the issue description.

    Meanwhile please try recreating a new key and let me know if this helps.

    Thanks in advance!
  • HarryB
    13
    We just found out that there is a small bug with saving the key to the file indeed, could you copy it manually and send it to me in a new txt file?

    Thanks in advance.
  • Allan
    1
    Based on your comment above, when I create a new key and copy and paste it to a file (instead of using the save to a file option) the key is now valid and can be used to gain access to the object computer.
    After that I found another issue. The object computer is a recent build and was configured with a Microsoft account and PIN to sign in. Remote access was being rejected with invalid credentials. In desperation, I changed the login to a local account and a traditional password - the remote access is now working.
    Thanks for your help, this issue is now resolved in my case.
  • HarryB
    13
    Hi ,

    Thanks a lot for your feedback, I was glad to help!
bold
italic
underline
strike
code
quote
ulist
image
url
mention
reveal
youtube
tweet
Add a Comment